Bug #3329

Incompatibilité Centreon avec php 5.4.0-3 de Debian Wheezy

Added by Thomas DU BOYS almost 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:05/21/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:duplicate

Description

Bonjour,

Il semblerait que l'interface web de Centreon ne soit pas compatible avec la version de PHP incluse dans Debian Wheezy (testing).

Dans cette configuration, à l'ouverture d'une fiche de hosts, de services ou tout autre, les checkbox "yes, no, default" sont toutes à vide, alors qu'au moins une devrait être cochée.
De plus, et c'est plus gênant, lors de l'ajout ou de la modification d'un host, ou d'un service, celui-ci est bien créé en base, mais n'apparait pas dans la liste des hosts ou des services, et n'est pas généré lors de l'export de la conf.

Si on supprime tout les paquets PHP de Debian Wheezy et qu'on installe ceux de Debian Squeeze, alors tout remarche bien, et si on les remets à jour, ça déconne de nouveau.

Ce souci est remonté par d'autres utilisateurs dans le forum : http://forum.centreon.com/showthread.php/12686-hote-crée-n-apparait-pas-dans-centreon

Versions de paquets concernés :
- centreon 2.3.8 (testé avec 2.3.7, même souci)
- centreon-engine 1.1.2
- centreon-broker 2.2.1
- Apache 2.2.22-5 ou nginx 1.1.19-1
- PHP 5.4.0-3

Et cela fonctionne si on remplace PHP par la version 5.3.3-7

Merci !


Related issues

duplicates Centreon-Core - Bug #3239: PHP 5.4 compatibility New 04/16/2012

History

#1 Updated by Quentin Garnier almost 2 years ago

Bonjour,

Nous n'avons pas encore validé centreon avec la version php 5.4 qui est très récente. Vos problèmes sont donc peut être normal.

#2 Updated by Anonymous over 1 year ago

  • Target version set to Pending

Bonjour,

nous traiterons ce sujet lorsque nous travaillerons sur la compat. php 5.4+

#3 Updated by Brice Lilot over 1 year ago

Bonjour,

Avec une machine tournant sous Debian "Instable", il est possible de faire fonctionner Centreon en utilisant PHP 5.3 des dépots stables.

Je confirme l'impossibilité de travailler avec PHP 5.4 et Centreon.
Je viens de dupliquer la machine virtuelle sur laquelle j'avais PHP 5.3 + Centreon pour fournir de plus amples informations quand aux problèmes de compatibilité.

#4 Updated by Anonymous over 1 year ago

  • Status changed from New to Closed
  • Target version deleted (Pending)
  • Resolution set to duplicate

Also available in: Atom PDF