Bug #2832

Problème caractères spéciaux dans "Advanced matching rules"

Added by Guillaume Watteeux over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:11/25/2011
Priority:NormalDue date:
Assignee:Sylvestre Ho% Done:

100%

Category:Centreon - Configuration
Target version:Centreon 2.3.4
Resolution:fixed

Description

Bonjour,

Dans la configuration des traps, lorsque l'on utilise les regex dans Advanced matching rules, les caractères spéciaux "\", "'" sont modifiés lors de la sauvegarde. Les "\" disparaissent alors que pour "'", c'est traduit en html.

Cdt
WAtt

History

#1 Updated by Sylvestre Ho over 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Sylvestre Ho
  • Target version set to Centreon 2.3.4

#2 Updated by Guillaume Watteeux over 2 years ago

Voici la notation en base:

+----------------------+------------+------------+
| tmo_regexp           | tmo_status | tmo_string |
+----------------------+------------+------------+
| /'1'(.*$)/ |          0 | @OUTPUT@   | 
| /'3'(.*$)/ |          2 | @OUTPUT@   | 
+----------------------+------------+------------+

#3 Updated by Sylvestre Ho over 2 years ago

  • Status changed from Assigned to Solved
  • % Done changed from 0 to 100
  • Resolution set to fixed

revision r12748

Pourrais-tu valider que cela ne créé pas d'effet de bord avec le centTrapHandler stp? (à priori ça devrait passer)

Merci!

#4 Updated by Julien Mathis over 2 years ago

  • Status changed from Solved to Closed

Also available in: Atom PDF