Bug #2146

Install process / mysql tables is broken with recent mysql server

Added by Nicolas GORALSKI about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:01/27/2011
Priority:HighDue date:
Assignee:Julien Mathis% Done:

100%

Category:Installer
Target version:Centreon-2.2
Resolution:fixed

Description

With a Mysql server 5.0.77-4.el5 everything is ok.
With Mysql server advanced 5.5.8-1.rhel5 some tables are missings.

Reason, when creating with the sql file createTables the order :
`update_acl` enum('0','1') default 0

Doesn't work inside mysql Server Advanced but on 5.0.

Other commands are with simple quote for default value like `update_acl` enum('0','1') default '0'

So i change every enum with default value wo quote.

Patch is attached, waiting for validation.

createTables.patch Magnifier - Patch for (1.12 KB) Nicolas GORALSKI, 01/27/2011 01:35 pm

Associated revisions

Revision 26644473
Added by Julien Mathis about 3 years ago

fix #2146

git-svn-id: http://svn.centreon.com/trunk/centreon@11531 6bcd3966-0018-0410-8128-fd23d134de7e

History

#1 Updated by Julien Mathis about 3 years ago

  • Target version changed from Centreon-2.1.10 to Centreon-2.2

Thanks for this patch. We will take times in integrate it soon.

Regards

#2 Updated by Julien Mathis about 3 years ago

  • Status changed from New to Solved
  • % Done changed from 80 to 100

Applied in changeset r11531.

#3 Updated by Julien Mathis about 3 years ago

  • Status changed from Solved to Closed
  • Assignee set to Julien Mathis
  • Resolution set to fixed

Also available in: Atom PDF