Bug #1253

Event Log problem

Added by benoit de jocas over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:10/06/2009
Priority:HighDue date:
Assignee:Julien Mathis% Done:

100%

Category:CentWeb
Target version:Centreon-2.1.2
Resolution:fixed

Description

Hi !
I have two issues with the Event Log...
the first one (screen : event log error 1) is about the hours displayed in the event log. It's easy to understand after seeing the screen shot. It seems that the log are not in the good order... sorry i can't explain it clearly (I'm French).

Second issue : Yesterday my Centstorage database has grown fast, really fast... 700Mb (1.7Gb to 2.35Gb).
I think it's the table corresponding to the event log which has grown up ! :)
Take a look at the screen shot (event log error 2 and 3). An error is displayed hundreds of time instead of one.
All my host have more than 300 pages of log....

Perhaps i know the reason. Yesterday, my report page in centreon display all my host and service in the Unknown state whereas in the monitoring pages, everything was fine.
I did :
./logAnalyser -a
./archiveDayLog -r

I don't know if that the reason of this error, but it's the only action I've made yesterday.

Can you help me ?

Sorry for my English =S

event_log_error_1.JPG (77 KB) benoit de jocas, 10/06/2009 10:32 am

event_log_error_2.JPG (264 KB) benoit de jocas, 10/06/2009 10:32 am

event_log_error_3.JPG (261 KB) benoit de jocas, 10/06/2009 10:32 am

stalking.JPG (10.9 KB) benoit de jocas, 10/06/2009 11:46 am

eventlog.JPG (68.3 KB) benoit de jocas, 10/06/2009 02:11 pm

Eventlog-error4.JPG (209 KB) benoit de jocas, 10/12/2009 10:07 am

Eventlog-error5.JPG (214 KB) benoit de jocas, 10/12/2009 11:24 am

History

#1 Updated by Julien Mathis over 4 years ago

  • Category set to CentWeb
  • Status changed from New to Assigned
  • Assignee set to Julien Mathis
  • % Done changed from 0 to 50

Hi,

No worry ! I'm frensh too :) I understand your difficulties :)

1) I will fixe the order problem

2) Please do not enable your stalking options. This options is not necessary all the time. Only for specific case. Each time nagios execute a check, the result is store in the log file. That why you DB grows up too fast. It's not a bug. It's a configuration problem.

#2 Updated by benoit de jocas over 4 years ago

Stalking option ? Did I enable it when i did this : ./archiveDayLog -r ????
Can you tell me how to remove it ?

1) thx for that :)

#3 Updated by Julien Mathis over 4 years ago

no when you change service or service template configuration...

#4 Updated by benoit de jocas over 4 years ago

Is there a way to erase the event log ? I've 300 pages for each host, and it takes a lot of time to display it. :(
Strange thing is that my centreon server work for 2 month now, and it's the first time I see that!

Thx for your help and good job with Centreon, it's a very usefull soft :)

#5 Updated by benoit de jocas over 4 years ago

Stalking option wasn't activated.

Like i said, Centreon worked perfectly for 2 month, and it happens all of a sudden, yesterday.
All my services are configured since the beginning so i don't think it's a configuration problem.

#6 Updated by Julien Mathis over 4 years ago

  • % Done changed from 50 to 100

r9162
r9163

Please, can you test ?

Thanks

For DB problem : is nagios log file bigger than before ?

#7 Updated by benoit de jocas over 4 years ago

Julien Mathis wrote:

r9162
r9163

Please, can you test ?

Of course, is this for the order problem? ;)

For DB problem : is nagios log file bigger than before ?

Apparently no.

#8 Updated by Julien Mathis over 4 years ago

Do you use daily rotation method in nagios.cfg ?

#9 Updated by benoit de jocas over 4 years ago

yes

#10 Updated by benoit de jocas over 4 years ago

#11 Updated by benoit de jocas over 4 years ago

can this be related to my issue ?

[1254839304] Warning: The check of host 'cbh122' looks like it was orphaned (results never came back). I'm scheduling an immediate check of the host...

[1254839304] Warning: The check of host 'cbh21' looks like it was orphaned (results never came back). I'm scheduling an immediate check of the host...

[1254839304] Warning: The check of host 'cbh24' looks like it was orphaned (results never came back). I'm scheduling an immediate check of the host...

[1254839311] Warning: The check of host 'cbh19' looks like it was orphaned (results never came back). I'm scheduling an immediate check of the host...

#12 Updated by benoit de jocas over 4 years ago

Is it normal that my Centstorage database is still growing (not much but...) even if Nagios, Ndo and Centstorage process are shutdown ?

#13 Updated by benoit de jocas over 4 years ago

I redo the update part (2.0.2 => 2.1.1)
Everything was fine, except the log_action table (already fixed) and the dashboard which only showed Unknown state for Host and services.

At this point, my Event log was fine... 1 line for 1 state.

I did the same manipulation than before :

./logAnalyser -a
After that, my log was fine ... (normal...)

And then : ./archiveDayLog -r
After that, my dashboard was ok but the Event Log started acting crazy ! 30-40 lines (sometimes mores) for a same state... (same host, same hours, same messages...) Like the event_log_error2.jpg show.

Is the archiveDayLog is bugged ?
Plz I need a response, I know you have a lot of work, but it's driving me and my database crazy ! :)
Thanks a lot.

#14 Updated by Julien Mathis over 4 years ago

Can you test this patch ?

r9190

Thanks

#15 Updated by benoit de jocas over 4 years ago

Julien Mathis wrote:

Can you test this patch ?

r9190

This isn't changing anything.
Check the new screen... multiple log and the hour is false again ! :(

I use the r9162 because the r9163 bug, i have an XML error on the EventLog page.

Tomorrow is the end of my internship so I have until the end of the day to fix it. After that, I'll go back to the 2.0.2 version.

#16 Updated by Julien Mathis over 4 years ago

and with a loganalyser -r ?

#17 Updated by Julien Mathis over 4 years ago

  • Target version changed from Centreon-2.1.1 to Centreon-2.1.2

#18 Updated by benoit de jocas over 4 years ago

Julien Mathis wrote:

and with a loganalyser -r ?

u mean logAnalyser -a ? or archiveDayLog -r ? :p

#19 Updated by benoit de jocas over 4 years ago

I did a logAnalyser -a and an archiveDayLog -r.
As you can see, it's not better.

Here some new entiers in my nagiosPerfTrace.log :

Possible unintended interpolation of @: in string at /usr/local/centreon/bin/nagiosPerfTrace line 296.

Possible unintended interpolation of @NAGIOS_GROUP in string at /usr/local/centreon/bin/nagiosPerfTrace line 296.

Global symbol "@CENTREON_ETC" requires explicit package name at /usr/local/centreon/bin/nagiosPerfTrace line 45.

Global symbol "@CENTREON_VARLIB" requires explicit package name at /usr/local/centreon/bin/nagiosPerfTrace line 47.

Global symbol "@CENTSTORAGE_LIB" requires explicit package name at /usr/local/centreon/bin/nagiosPerfTrace line 67.

Global symbol "@NAGIOS_USER" requires explicit package name at /usr/local/centreon/bin/nagiosPerfTrace line 296.

Global symbol "@NAGIOS_GROUP" requires explicit package name at /usr/local/centreon/bin/nagiosPerfTrace line 296.

BEGIN not safe after errors--compilation aborted at /usr/local/centreon/bin/nagiosPerfTrace line 312.

#20 Updated by Nikolaus Filus over 4 years ago

replace the original files from install dir with the ones from svn and re-install. alternatively you can replace those MACRO strings with your values.

#21 Updated by benoit de jocas over 4 years ago

Nikolaus Filus wrote:

replace the original files from install dir with the ones from svn and re-install. alternatively you can replace those MACRO strings with your values.

Re-install centreon completely ? If that what you mean, I don't have time for that :(
My internship ends tomorrow and I have others stuff to do ! :(

I'm going to replace the macro string!

#22 Updated by Julien Mathis over 4 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF