Bug #1004

Configuration upload: relation between host services and servicegroup missing

Added by Peeters Jan about 6 years ago. Updated over 5 years ago.

Status:ClosedStart date:06/26/2009
Priority:HighDue date:
Assignee:Sylvestre Ho% Done:


Target version:Centreon-2.2
Resolution:fixed Affect Version:


snippet servicegroups.cfg
define servicegroup{
servicegroup_name Allsites_enabled
alias Allsites_enabled
members xxxxx,xxxxx,xxxxx,xxxxx,xxxxx

If I add services via 'Nagios Configuration Files Export' like this:
define service{
host_name yyyyyy
service_description SWRAID
use ST-NRPE-swraid
servicegroups Allsites_enabled

the service is added but there is no relation with the servicegroup.
Not in the Centreon Services Groups windows nor in the Nagios cfg file.


#1 Updated by Peeters Jan almost 6 years ago

Are you able to reproduce this bug? Can this be fixed in the 2.2 version?

#2 Updated by Nikolaus Filus almost 6 years ago

  • Priority changed from Normal to High
  • Target version set to Centreon-2.2

Thats right. The key "servicegroups" is not handled (and missing) in www/include/configuration/configLoad/DB-Func.php:insertServiceCFG()

#3 Updated by Julien Mathis over 5 years ago

  • Category set to CentWeb
  • Status changed from New to Solved
  • Assignee set to Sylvestre Ho
  • % Done changed from 0 to 100
  • Resolution set to fixed

#4 Updated by Julien Mathis over 5 years ago

  • Status changed from Solved to Closed

Also available in: Atom PDF